アラ還のオッサンがマルクスの勉強やらコンサートの感想やらを書き込んでいます

MT-3.2beta4が出たけれど

2005年8月14日 at 15:03:14

MT-3.2beta4が出ました。

ダウンロードして早速サーバーにインストールしてみましたが、rebuildのところでエラーが出てうまくいきません。styles-site.cssに<MTLink>タグがありません、とエラーメッセージが表示されるのですが、なんで.cssにタグが必要なんだ? わからん…

Movable Type 3.2 Beta – Finally updated sidebar

Similar Articles:

Tags:

Print This Post Print This Post

人気ブログランキングに参加しています。よかったらクリックしてください。

4 Responses to “MT-3.2beta4が出たけれど”

  1. typoがあるのでエラーになっちゃいます。
    indexテンプレート内のatom.xmlがダブルクォーテーションで括られていないので

    <a href="<$MTLink template="atom.xml$>">Subscribe to this blog’s feed</a><br />

    から

    <a href="<$MTLink template="atom.xml"$>>Subscribe to this blog’s feed</a><br />

    に書き替えてみてください。これでエラーは出なくなるはずです。

  2. indexテンプレート内のこれを

    <h2 class="module-header"><a href="<$MTLink template="style-site.css"$>">Archives</a></h2>

    にすると直るかもしれません。

    <h2 class="module-header"><a href="<$MTLink template="Master Archive Index"$>">Archives</a></h2>

  3. >MT4989さん
    情報ありがとうございます。
    教えていただいた箇所を修正しただけでは、エラーは消えませんでした。どうも、Main Index, Atom Index, Master Archive Indexだけじゃなくて、Individual Entry ArchiveとCategory Archiveの各テンプレートにもエラーがあるみたいです。
    ということで、とりあえずNightly 20050809-2のテンプレートを上書きしたら、エラーは消えました。

    最後のbeta版だというのに、なんか不安…。

  4. 3.17usから3.12beta4へバージョンアップしたとき
    mt-site.jsが最初なかったのでsite_javascript.tmplの内容をコピー、Create New Index Templateで作成、ペースト。出力ファイル名:mt-site.js 名前:Site JavaScript
    それと上述のtypoを訂正で再構築。
    で一応エラーもなく動いています。

Trackback This Post

http://ratio.sakura.ne.jp/archives/2005/08/14150314/trackback/

Leave a Reply